Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
SWAPdmt error - Gdk-CRITICAL
02-25-2017, 04:23 AM
Post: #1
SWAPdmt error - Gdk-CRITICAL
Hi Daniel,

I'm trying to run the SWAPdmt GUI but I'm having some problems. When I execute (in python_tools-3.1.3/swapdmt) "python pyswapdmtgui.py" then I get the following error message:

"(pyswapdmtgui.py:2175): Gdk-CRITICAL **: IA__gdk_window_get_origin: assertion 'GDK_IS_WINDOW (window)' failed"

I'm able to se the window of the SWAP Device Management Tool but I can't see the options "File", "Gateway", "Devices" and "Help".

Do you have maybe any clue about what I'm doing wrong?

I've tried installing different versions of GTK+, wxpython and python_tools but nothing Sad

thanks! Smile

by the way, I'm using Ubuntu 16.04.2 amd64
Find all posts by this user
Quote this message in a reply
02-27-2017, 12:36 AM
Post: #2
RE: SWAPdmt error - Gdk-CRITICAL
SWAPdmt GUI is a bit outdated since we released the command-line tool to avoid this kind of issues:
https://github.com/panStamp/panstamp/wik...e-version)

GTK is indeed evolving but we are doing nothing to update the tool. I'm sorry Sad

Daniel Berenguer
http://www.panstamp.com
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)